Knowledge Base Article
Article Type: Troubleshooting
Product: Symphony
Product Version:
Component: Symphony Server
Device Brands:
Created: 10-Sep-2020 2:34:09 PM
Last Updated:

Custom SSL certificate stops working

Issue

Custom SSL certificates do not work and browsers display security warning when you try to open the Symphony Server configuration interface.

Cause

It is possible that you do not have permission to write the certificate's private key to the machine store. Initially, the certificate is loaded into memory, and it works for that session, but then fails for subsequent sessions.

Resolution

To resolve this issue, import the certificate again. For multi-server farms, you must perform this procedure on each server in the farm.

  1. Add the certificate to the Symphony Server configuration interface.
  2. Confirm that the binding is added (netsh http show sslcert) and that the certificate is present in the store ( certutil -store My ).
    Note: At this point, certutil shows Encryption test passed for the custom ssl certificate.
  3. Reboot the server.
  4. Run certutil -store My .
    Note: At this point, certutil shows Missing store keyset.
  5. Import the same certificate (either through the console or by double-clicking the certificate) and place it in Personal.
  6. Confirm that you can still access the Symphony Server configuration interface.
  7. Reboot the server and confirm that you can still access the Symphony Server configuration interface.

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